Problem with SyntaxHighlighter Evolved in WordPress MU 2.7.1

I installed SyntaxHighlighter Evolved a couple of days ago but I wasn’t sure how to use, I couldn’t get it to work. After a while I saw the following error message “Warning: htmlspecialchars_decode() expects parameter 1 to be string”. After a quick Googling for that phrase I found this post that led me to the the following bug report with the solution.

The line in error is line 104 in wp-includes/compat.php:

if ( !is_scalar( $string ) ) {

should be

if ( !is_scalar( $str ) ) {

I did the change and now it works perfect. 🙂